PDA

View Full Version : Gamebreaking Bug/Glitch.



xvdaemonicxv
01-12-2013, 10:13 PM
I know there is a bug thread but it seems to be spammed full of off topic comments and etc. I have posted my bug on there too. The only reason I am making a separate thread about this is because I believe this is the most important glitch/bug that needs to be addressed.

http://24.media.tumblr.com/66a5678d75569a37ebdc655475868b0d/tumblr_mgjsspE1cx1rzvs1to1_1280.png

As you can see I clearly have won the game. His army was decimated, so was his economy. It was a giant battle and he was losing so he sent all his miners as meatshield.
This was not a spearton rush to my base where I lost, if it was, I wouldnt be busy killing his miners. Also, I know how to counter spearton base rushers. Trust me.

This is what happened. I am winning the game. My opponent surrenders. It says he is lagging and will be timed out. Then it says I AM LAGGING. And my counter goes down first so I lose. This needs to be fixed. This is a rare occurence but so far it is the third time it's ever happened to me.

Sorry I do not have video proof of the whole thing taking place. Since it is a somewhat rare occurance I can't just be videoing my matches all day. There are other players that can vouch for me that this has happened to them also.

malbence
01-12-2013, 10:16 PM
Yeah this happens.

Until they fix this, if ever, if you have such a great lead, try sacrificing out your units one by one (easier if he has castle archers. :P). wait until all his units are dead and then kill off all of your miners, then use 2 or 3 speartons and finish off the statue. The idea is to minimize activity on the screen, because more action = more lag. The problem is that with the big animation of the statue falling and all that computers start to lag. I think the developers just need to cut to the victory screen right after a statue is decimated. No animation, nothing.

xvdaemonicxv
01-12-2013, 10:20 PM
Ahh so thats why... Thanks for the info! :))

jerrytt
01-12-2013, 10:21 PM
Sometimes, I beleive this is used as an exploit. I dont know the specifics but I think it has to do with surrendering or pausing while your statue is destroyed or something like that.

xvdaemonicxv
01-12-2013, 10:23 PM
I see, however I did not destroy his statue. He just surrenderd. I think it's still just a bug/glitch and not a exploit. I hope.

lntrepid
01-12-2013, 10:25 PM
It happens alot for me too... fortunatly I only run stick empires on my browser and it works fine.
But it is very annoying when it happens on ranked matches.

xvdaemonicxv
01-12-2013, 10:27 PM
Happened twice to me and each time when I got to rank 1 8D.

jerrytt
01-12-2013, 10:27 PM
well at least it was an 1800 and not a 1600

stickman311
01-13-2013, 05:35 AM
At least its not a 0 either lol

3FFA
01-13-2013, 05:52 AM
I've heard rumors of it being an exploit.

uberman
01-13-2013, 05:55 AM
Sometimes, I beleive this is used as an exploit. I dont know the specifics but I think it has to do with surrendering or pausing while your statue is destroyed or something like that.

Yes, indeed I posted a comment about this exploit.

And yes, I think the lag out happens as a random event as described in the OP, as it seems to have happened that way to me too.